Uživatelské nástroje

Nástroje pro tento web


Nastavení záložního připojení přes LTE pomocí mwan3

Tento návod je určen pro routery Turris Omnia s aktivním připojení k síti přes LTE a WAN. Cílem je nastavit připojení do režimu failover, kdy je primárně použito připojení přes WAN a v případě jeho výpadku je veškerý provoz směrován přes LTE.

Pro tento účel je použita služba mwan3, která nahrazuje starší a dále již neudržovanou službu Multiwan.

Služba mwan3 je určena pro připojení přes různé poskytovatele, z tohoto důvodu nebude fungovat pokud ji použijete pro více připojení se stejným rozsahem IP adres.

Ověření připojení

Před zahájením instalace a nastavení služby mwan3 je vhodné ověřit, že jsou obě připojení LTE i WAN funkční. V případě že tomu tak není, je nutné je nejdříve zprovoznit (např. podle návodu na zprovoznění LTE ).

Připojení ověříme pomocí příkazu ping :

root@turris:~#  ping -c 1 -I eth1 8.8.8.8
root@turris:~#  ping -c 1 -I 3g-lte 8.8.8.8

Název rozhranní pro lte bude, v případě že jste postupovali podle návodu na zprovoznění lte, 3g-lte. Případně jej lze získat z výpisu příkazu ifconfig jako rozhranní, které používá protokol Point-to-Point.

Nastavení statického routování a firewallu

Nejdříve nastavíme statické routování pro obě připojení tak, abychom po spuštění systému směrovali veškerý síťový provoz přes rozhranní WAN. To docílíme v rámci konfigurace /etc/config/network, kdy pro sekci interface 'wan' nastavíme hodnotu metric '10', v sekci interface 'lte' vypneme použití standartního routování volbou defaultroute '0' a poté přidáme sekci s novým routovací pravidlem route 'lte_route', které se použije pro rozhranní lte.

Jednotlivé položky v rámci routovacího pravidla route 'lte_route' nastavíme podle ukázky /etc/config/network. Položky target a netmask nastavíme adresu 0.0.0.0 která určuje defaultní routovací pravidlo. Adresu pro gateway nastavíme na 10.64.64.64, což je standardně používaná adresa při připojení pomocí protokolu PPP (Point-to-point protocol), případně lze tuto adresu zjistit pomocí příkazu ifconfig.

Pro LTE musí být metrika vyšší než pro WAN připojení, protože pro routování se použije cesta s menší metrikou. Více informací o možných volbách konfigurace lze získat z wiki OpenWrt (v angličtině).

/etc/config/network
config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option defaultroute '1'
        option metric '10'
 
config interface 'lte'
        option proto '3g'
        option device '/dev/ttyUSB2'
        option service 'umts'
        option apn 'internet'
        option pincode '1234'
        option ipv6 'auto'
        option defaultroute '0'
 
config route 'lte_route'
        option interface 'lte'
        option target '0.0.0.0'
        option gateway '10.64.64.64'
        option netmask '0.0.0.0'
        option metric '50'

lte je logické označení v rámci konfiguračního souboru /etc/config/network a liší se tedy od názvu rozhranní získaného příkazem ifconfig.

Posledním krokem je nastavení connection tracking v konfiguraci firewallu /etc/config/firewall . V rámci zóny wan stačí nastavit volbu conntrack '1'.

/etc/config/firewall
config zone
        option conntrack '1'
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 lte'

Instalace a nastavení mwan3

Službu mwan3 není možné současně provozovat se službou multiwan. V případě, že je služba Multiwan nainstalována, je nutné ji deaktivovat zadáním následujících příkazů.

root@turris:~# /etc/init.d/multiwan stop
root@turris:~# /etc/init.d/multiwan disable

Poté nainstalujeme balíček mwan3:

root@turris:~# opkg update
root@turris:~# opkg install mwan3

Po instalaci mwan3 provedeme nastavení úpravou konfigurace v /etc/config/mwan3 . Defaultní konfiguraci vymažeme a nahradíme ji novou ve které definujeme sekci interface a member pro wan i lte a sekci policy a rule. Sekce rule 'default' určuje, že veškerý provoz bude směrován na základě pravidla definovaného v sekci policy 'wan_lte'.

/etc/config/mwan3
config interface 'wan'
	list track_ip '217.31.204.130'
	list track_ip '193.29.206.206'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	option enabled '1'
	option reliability '1'
	option count '1'
	option timeout '2'
	option interval '5'
	option down '3'
	option up '8'
 
config interface 'lte'
	list track_ip '217.31.204.130'
	list track_ip '193.29.206.206'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	option enabled '1'
	option reliability '1'
	option count '1'
	option timeout '2'
	option interval '5'
	option down '5'
	option up '10'
 
config policy 'wan_lte'
	list use_member 'wan_m1_w1'
	list use_member 'lte_m2_w2'
	option last_resort 'unreachable'
 
config member 'wan_m1_w1'
	option interface 'wan'
	option metric '1'
	option weight '1'
 
config member 'lte_m2_w2'
	option interface 'lte'
	option metric '2'
	option weight '2'
 
config rule 'default'
	option proto 'all'
	option sticky '0'
	option use_policy 'wan_lte'
	option dest_ip '0.0.0.0/0'

Jednotlivé položky v rámci daných sekcí mají tento význam.

Sekce interface

  • track_ip - IP adresa na které se bude testovat připojení
  • enable - aktivuje dané rozhranní
  • reliability - určuje kolik IP adres definovaných pomocí track_ip musí odpovědět na dotaz, aby mohl být daný interface považován za aktivní
  • count - počet dotazů, které budou zaslány na adresy definované jako track_ip v rámci testu
  • timeout - pauza v sekundách mezi posláním testovacích dotazů
  • interval - pauza v sekundách mezi provedením jednotlivých testů
  • down - počet neúspěšných testů, po kterém je spojení prohlášeno za neaktivní
  • up - počet úspěšných testů nutných pro označení spojení jako aktivní

Sekce members

  • interface - určuje rozhranní, ke kterému se vztahuje daná sekce members
  • metric - v rámci sekce policy mají položky members s menší hodnotou přednost před položkami s větší hodnotou
  • weight - sekce members se stejnou hodnotou metric distribuují přenášené data na základě poměru zadaných hodnot

Sekce policy

  • use_member - definuje seznam použitých položek members
  • last_resort - určuje co se stane s pakety v případě, že budou všechny rozhranní definované pomocí use_member neaktivní. Možné hodnoty jsou unreachable (u paketů se vrátí odpověd unreachable), blackhole (pakety budou potichu zahozeny) nebo default

Sekce rule 'default'

Nastavuje standardní směrovací pravidlo použité pro veškerá přenášená data.

  • proto - vymezuje protokoly pro které se dané pravidlo uplatní
  • sticky - umožní směrovat data se stejnou zdrojovou IP adresou v rámci původního rozhranní po dobu nastavenou jako timeout limit
  • use_policy - definuje použitou policy
  • dest_ip - nastavuje cílovou IP adresu (případně rozsah adres) pro kterou bude pravidlo použito. ( 0.0.0.0/0 určuje použití pro všechny cílové adresy)

Nakonec spustíme službu mwan3 a restartujeme služby network a firewall

root@turris:~# mwan3 start
root@turris:~# /etc/init.d/network restart
root@turris:~# /etc/init.d/firewall restart

Název sekce interface musí odpovídat názvu rozhranní z konfiguračního souboru /etc/config/network

Testování

Kontrolu správného nastavení služby mwan3 provedeme pomocí příkazu

root@turris:~# mwan3 status

Pro otestování připojení můžeme použít některou z webových služeb (např. http://ip4.me ), které zobrazí veřejnou IP adresu. Po odpojení kabelu od rozhranní WAN by měl systém automaticky přesměrovat provoz přes LTE, což se projeví změnou vypisované IP adresy.

Další možnosti využití a konfigurace služby mwan3 jsou popsány na wiki OpenWrt (v angličtině).